راه‌اندازی لود بالانسینگ با متد NTH – میکروتیک

/ 18 دسامبر 16

با نحوه راه‌اندازی سرویس لودبالانسینگ با متد nth در مقاله آموزشی زیر آشنا می‌شویم. این روش یکی از روش‌های ساده و کاربردی برای راه‌اندازی سرویس Load Balancing در میکروتیک برای چند لینک اینترنت هم وزن می‌باشد. هم وزن از نظر میزان پهنای باند مثلاً دو لینک Wan با پهنای باند هر لینک ۱ مگابیت بر ثانیه.

برای راه‌اندازی این سرویس در میکروتیک از ابزار‌های بخش Mangle برای علامت‌گذاری پکت‌های درون شبکه برای انتقال موازی بین دو لینک Wan استفاده می‌کنیم:

/interface ethernet
set 0 name=WAN1
set 1 name=WAN2
set 2 name=internal

بعد از نام‌گذاری Interface ها باید روی آن‌ها آدرس IP را تنظیم کنیم:

/ip address
add address=192.168.50.2/24 network=192.168.50.0 broadcast=192.168.50.255 interface=WAN1
add address=192.168.51.2/24 network=192.168.50.0 broadcast=192.168.50.255 interface=WAN2
add address=192.168.22.1/24 network=192.168.22.0 broadcast=192.168.22.255 interface=internal

سپس با استفاده از ابزار Mangle متد nth را پیاده‌سازی کرده و پکت‌ها را علامت‌گذاری و برای آن‌ها Routing-Mark جداگانه‌ای تنظیم می‌کنیم:

/ip firewall mangle
add chain=prerouting in-interface=internal connection-state=new nth=2,1 action=mark-connection new-connection-mark=conn1 passthrough=yes comment=”” disabled=no
add chain=prerouting in-interface=internal connection-mark=conn1 action=mark-routing new-routing-mark=conn1 passthrough=no comment=”” disabled=no
add chain=prerouting in-interface=internal connection-state=new nth=2,2 action=mark-connection new-connection-mark=conn2 passthrough=yes comment=”” disabled=no
add chain=prerouting in-interface=internal connection-mark=conn2 action=mark-routing new-routing-mark=conn2 passthrough=no comment=”” disabled=no

 

برای هر یک از کانکشن‌های فوق یک رول Nat از نوع Masquerade نیز ایجاد می‌کنیم:

/ip firewall nat
add chain=srcnat connection-mark=conn1 action=masquerade out-interface=WAN1 comment=”” disabled=no
add chain=srcnat connection-mark=conn2 action=masquerade out-interface=WAN2 comment=”” disabled=no

در نهایت با استفاده از رول‌های قسمت route ترافیک را به سمت Gateway‌های موجود ارسال می‌‌کنیم.

/ip route
add dst-address=0.0.0.0/0 gateway=192.168.50.1 scope=255 target-scope=10 routing-mark=conn1 comment=”” disabled=no
add dst-address=0.0.0.0/0 gateway=192.168.51.1 scope=255 target-scope=10 routing-mark=conn2 comment=”” disabled=no
add dst-address=0.0.0.0/0 gateway=192.168.50.1 comment=”” disabled=no
add dst-address=0.0.0.0/0 gateway=192.168.51.1 comment=”” disabled=no

 

 

LiveZilla Live Chat Software سوال خود را با ما مطرح کنید