راه‌اندازی VPN سرور با قابلیت لاگ‌گیری – میکروتیک

/ 25 ژانویه 17

در این مقاله آموزشی قصد داریم با نحوه راه‌اندازی یک VPN سرور با قابلیت لاگ‌گیری از سایت‌های باز شده در میکروتیک آشنا شویم. در برخی از شبکه‌ها با توجه به نیاز سازمان باید روی اینترنت محدودیت‌هایی اعمال شود مثلاً فایل‌های MP3 در ساعات اداری دانلود نشود و یا برخی از سایت‌های خاص فیلتر شود و…

در کنار سیاست‌های فوق نیاز به دریافت لاگ از سایت‌های بازدید شده و فایل‌های دانلود شده و … نیز می‌باشد.

یکی از این راهکار‌ها ابزار VPN+Web Proxy میکروتیک می‌باشد.

برای اجرای این سناریو به ترتیب موارد زیر را اجرا می‌کنیم:

ایجاد یک Pool آدرس IP مختص کاربران اینترنت

/ip pool

add name=VPN ranges=10.50.50.2-10.50.50.199

سپس برای فعال‌سازی سرویس VPN Server روی روتر باید یک Profile برای مشخصات و تنظیمات سرور خود در میکروتیک ایجاد کنیم:

/ppp profile

add dns-server=8.8.8.8,4.2.2.4 idle-timeout=59m local-address=10.50.50.1 \

    name=”Local VPN” remote-address=VPN

سپس سرویس VPN سرور را فعال می‌کنیم:

/interface pptp-server server

set authentication=pap,chap,mschap1,mschap2 default-profile=”Local VPN” \

    max-mru=1460 max-mtu=1460

در این سناریو من از سرویس PPTP استفاده می‌کنم.

اکنون قابلیت اتصال کاربران به سرور فراهم شده است و باید نسبت به تخصیص اینترنت به آن‌ها اقدام کنیم.

در ابتدا سرویس web proxy را در میکروتیک فعال می‌کنیم:

/ip proxy

set anonymous=yes cache-administrator=BehdadRahmani cache-on-disk=yes cache-path=\

    primary-slave/lost+found enabled=yes port=3128 src-address=X.X.X.X

بعد از فعال شدن سرویس پراکسی باید با استفاده از یک رول Nat به شکل زیر تمام ترافیک سرویس http کاربران به سمت Proxy Server خود ارجاع می‌دهیم. این سرویس تحت عنوان Transparent Proxy Server نیز شناخته می‌شود زیرا کاربران متوجه فعال بودن این سرویس و گزارش‌گیری نخواهند شد و نکته بعدی با توجه به این‌که میکروتیک در نقش یک cache سرور نیز فعالیت می‌کند می‌تواند تا حد زیادی در بهبود کیفیت اینترنت داخلی فعالیت داشته باشد.

/ip firewall nat

add action=redirect chain=dstnat dst-port=80 protocol=tcp to-ports=3128

 

برای فعال کردن قابلیت گزارش‌گیری از سایت‌های باز شده و فایل‌های دانلود شده نیز از دستور زیر استفاده می‌کنیم:

/system logging

add topics=web-proxy,!debug

system logging

 

VPN+Proxy logging

بهداد رحمانی

LiveZilla Live Chat Software سوال خود را با ما مطرح کنید