پاک کردن دوره‌ای لاگ‌های User Manager – میکروتیک

/ 27 دسامبر 16

 با پاک کردن دوره‌ای لاگ‌های User Manager در میکروتیک در مقاله آموزشی زیر آشنا می‌شویم.

یکی از امکانات خوب میکروتیک برای سازمان‌ها و شرکت‌ها با کاربر کم یا متوسط و نیازمند حسابداری اینترنت با امکانات محدودتر نسبت به نرم‌افزارهای مشابه حرفه‌ای پکیج User Manager می‌باشد که بر روی میکروتیک نصب می‌شود و نیازمند سیستم مجزا نمی‌باشد.

این نرم‌افزار خوب و گاهاً بسیار کارگشا در مواردی برای میکروتیک مشکلاتی ایجاد می‌کند که می‌بایست با نوشتن اسکریپت‌های خاص آن موضوع مشکلات را به حداقل رساند.

در این آموزش به یکی از این مشکلات که پر شدن هارد و اشغال شدن CPU به سبب حجم بالای لاگ‌های User Manager است می‌پردازیم.

در بسیاری موارد نیروهای پشتیبان برای پاسخ‌گویی به کاربران و پیدا کردن مشکلات اهراز هویت و … به لاگ‌های Authorization & Authorization & Accounting در User Manager نیازمند می‌باشند،در صورت فعال شدن این لاگ‌ها بعد از مدتی با زیاد شدن تعداد لاگ‌ها حجم هارد را تماما اشغال می‌کند و بار بر روی CPU را به شدت افزایش می‌دهد.

مراحل انجام کار :

ساخت اسکریپت

مطابق عکس زیر در Winbox به System>Scripts رفته و اسکریپتی به نام Rm_UM_log با منبع زیر ایجاد کنید.

 

Script List

 

دستورات ترمینال:

:local Flag
:set Flag [/tool user-manager log find]
:if ([:len $Flag] > 0) do={/tool user-manager log print append file log;/tool user-manager log remove [/tool user-manager log find];}

 

نوشتن زمان‌بندی

مطابق عکس زیر زمان‌بندی را ایجاد کنید یا دستورات زیر را در ترمینال وارد کنید تا به‌صورت خودکار هر ۷ روز یک‌بار لاگ User Manager پاک شود.

 

Scheduler

 

دستورات محیط ترمینال برای عکس بالا:

/system scheduler

 add name=”Rm-UM-log” on-event=”Rm_UM_log” start-date=Sep/15/2010 start-time=07:30:00 interval=7d comment=”” disabled=no

 

حتماً توجه داشته باشید برای اجرای صحیح این اسکریپت از قبل سرویس NTP برای به‌روزرسانی خودکار ساعت و تاریخ روتر شما فعال شده باشد.

بهداد رحمانی

LiveZilla Live Chat Software سوال خود را با ما مطرح کنید